Home » Tutorial » Firewall Untuk Keamanan Cloud Hosted Router Mikrotik Pada VPS

Firewall Untuk Keamanan Cloud Hosted Router Mikrotik Pada VPS

Kali ini saya ingin membagikan tutorial firewall untuk keamanan Cloud Hosted Router Mikrotik pada VPS. Cloud Hosted Router, selanjutnya disebut CHR mikrotik memiliki banyak kegunaan bagi penggiat bisnis jaringan internet, karna penggunaan CHR kebanyakan di install pada VPS maka kemanan sangat penting mengingat serangan dalam jaringan internet sangat banyak. Kali ini saya ingin membagi firewall untuk keamanan CHR yang saya pakai, skrip ini saya dapat dari beberapa forum dan saya implementasikan pada CHR milik saya.

Sebelumnya jangan lupa menambahkan address list untuk jaringan lokal pada IP – Firewall – Address List dengan nama PrivateIPs, atau bisa menggunakan nama lain namun harus diperhatikan skrip dibawah sesuaikan dengan pengaturan kamu.

/ip firewall filter
add action=drop chain=Attacks comment=\
    "Invalid packets (No valid current connection)" connection-state=invalid
add action=drop chain=Attacks comment="Invalid TCP flag combo" protocol=tcp \
    tcp-flags=!fin,!syn,!rst,!ack
add action=drop chain=Attacks comment="Invalid TCP flag combo" protocol=tcp \
    tcp-flags=fin,syn
add action=drop chain=Attacks comment="Invalid TCP flag combo" protocol=tcp \
    tcp-flags=fin,rst
add action=drop chain=Attacks comment="Invalid TCP flag combo" protocol=tcp \
    tcp-flags=fin,!ack
add action=drop chain=Attacks comment="Invalid TCP flag combo" protocol=tcp \
    tcp-flags=fin,urg
add action=drop chain=Attacks comment="Invalid TCP flag combo" protocol=tcp \
    tcp-flags=syn,rst
add action=drop chain=Attacks comment="Invalid TCP flag combo" protocol=tcp \
    tcp-flags=rst,urg
add action=drop chain=Attacks comment="Invalid TCP source port (0)" protocol=\
    tcp src-port=0
add action=drop chain=Attacks comment="Invalid TCP destination port (0)" \
    dst-port=0 protocol=tcp
add action=drop chain=Attacks comment="Invalid UDP source port (0)" protocol=\
    udp src-port=0
add action=drop chain=Attacks comment="Invalid UDP destination port (0)" \
    dst-port=0 protocol=udp
add action=return chain=Attacks comment="Return to the chain that jumped"
add action=jump chain=input comment="Check for bad stuff in \"Attack\" chain" \
    jump-target=Attacks
add chain=input comment=\
    "Allow current valid connections as well as valid related packets" \
    connection-state=established,related
add action=accept chain=input comment="Allow WWW" dst-port=80 protocol=tcp
add action=accept chain=input comment="Allow Winbox" dst-port=8291 protocol=\
    tcp
add action=accept chain=input comment="Allow L2TP VPN Protocol" dst-port=\
    500,4500,1701 protocol=udp
add action=accept chain=input comment="Allow L2TP Protocol \"IPSec\"" \
    protocol=ipsec-esp
add action=accept chain=input comment="Allow VPN PPTP" disabled=yes dst-port=\
    1723 protocol=tcp
add action=accept chain=input comment="Allow VPN SSTP" dst-port=443 protocol=\
    tcp
add chain=input comment="Allow the Private IP ranges to access the router" \
    connection-state=new src-address-list=PrivateIPs
add chain=input comment="Allow ICMP Response" icmp-options=8:0 protocol=icmp
add action=drop chain=input comment="Drop everything else by default"
add action=jump chain=forward comment=\
    "Check for bad stuff in \"Attack\" chain" jump-target=Attacks
add chain=forward comment=\
    "Allow current valid connections as well as valid related packets" \
    connection-state=established,related
add chain=forward comment=\
    "Allow the Private IP ranges to be forwarded by the router" \
    connection-state=new src-address-list=PrivateIPs
add action=drop chain=forward comment="Drop everything else on WAN1" \
    in-interface=ether1

Baca Juga: Install RouterOS Cloud Hosted Router MikroTik Cepat Tanpa Putty Di VULTR

Pada skrip firewall untuk keamanan Cloud Hosted Router Mikrotik pada VPS yang saya bagikan diatas kita memblokir semua port scanner, mengizinkan akses WWW, Winbox, SSTP, L2TP, PPTP, apabila ada yang tidak ingin kamu izikan bisa dihapus pada WinBox.

3 tanggapan pada “Firewall Untuk Keamanan Cloud Hosted Router Mikrotik Pada VPS”

  1. Pingback: Install RouterOS Cloud Hosted Router MikroTik Cepat Tanpa Putty Di VULTR

Komentar disini